W221 CAN-Bus komplett tot.

Diskutiere CAN-Bus komplett tot. im S-,S-Coupé, CL-, CLS-Klasse und Mercedes-Maybach Forum im Bereich Mercedes-Fahrzeuge; Hallo, Eine kurze Chronik von meinem Problem. Ich stelle das FZ Samstag-Abend ab. Dann klickt das SAM-Fond schon merkwürdig und die...

  1. #1 Jan_1710, 28.05.2021
    Jan_1710

    Jan_1710

    Dabei seit:
    28.05.2021
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,
    Eine kurze Chronik von meinem Problem.

    Ich stelle das FZ Samstag-Abend ab. Dann klickt das SAM-Fond schon merkwürdig und die Sitzverstellung funktioniert nicht einwandfrei. Habe mir nichts dabei gedacht. Bin dann ausgestiegen und habe abgeschlossen.

    Zwei Tage später musste ich dann zur Arbeit. Aber ich konnte das Auto nicht aufschließen.
    Schließlich ging es plötzlich doch und konnte auch gleich den Motor starten. Dabei ging das Licht immer an und aus, egal wie der Drehgriff stand. Bin dann los und mit der Zeit waren die Fehler auch wieder weg.

    Irgendwann ging es aber richtig los. Tankanzeige mal auf Null, mal auf Füllstand. RDK spinnt und ab und zu haben Blinker und Scheibenwischer nicht funktioniert. Auch die Tür wurde nicht als geschlossen erkannt.

    Zu Hause ging dann gar nichts mehr.
    Weder Fenster geht zu, noch der Motor startet. Außentemperatur zeigt 85 Grad an. ESP ohne Funktion. Kurzum = es geht gar nichts (außer das Herunterfahren des Heckdeckels). SAM und ZGW getauscht - bringt nichts. In der SD werden viele Steuergeräte gar nicht erkannt.

    Ich dachte an einen Kurzschluss, da mir in der SD dieser als Fehler angezeigt wird. Den habe ich aber schon seit Monaten. Irgendwo ein Kabelbruch? Aber wo?

    Kann mir jemand helfen?
     
  2. #2 Bytemaster, 28.05.2021
    Bytemaster

    Bytemaster

    Dabei seit:
    21.03.2010
    Beiträge:
    3.356
    Zustimmungen:
    832
    Auto:
    204.223 (C350CDI T) und 204.282 (C250CDI T 4matic)
    Verbrauch:
    Kennzeichen:
    u l
    bw
    o m * * *
    u l
    bw
    o m * * *
    Wie alt ist deine Batterie?
     
  3. #3 Jan_1710, 28.05.2021
    Jan_1710

    Jan_1710

    Dabei seit:
    28.05.2021
    Beiträge:
    6
    Zustimmungen:
    0
    Nahezu neu. Ich habe um das auszuschließen auch eine Stützbatterie parallelgeschaltet.
     
  4. #4 jpebert, 28.05.2021
    jpebert

    jpebert

    Dabei seit:
    07.11.2018
    Beiträge:
    4.989
    Zustimmungen:
    1.074
    Auto:
    S211 E280 CDI T vorMopf, S211 E280 T vorMopf, W211 E350 Mopf, VW LT 28 (1988), BMW X5 E70 - alles 6 Zylinder und weitere
    Dein Problem ist leider nicht so einfach zu lösen. Hilft nur eins, Du musst Dich durchmessen bis zum Fehler. Du kannst ein bisschen Fehlereingrenzung mit der Diagnose machen (Motorraum - CAN, Innenraum-CAN, ...) und dann nur noch messen.

    Wenn ich einen Tip ins Blaue geben darf. Die alten S-Klassen sind für Öl im Kaneblbaum und infolgedessen beliebige Fehler bekannt. Vielleicht checkst du das zunächst?
     
  5. stin

    stin

    Dabei seit:
    01.08.2011
    Beiträge:
    1.226
    Zustimmungen:
    213
    Auto:
    C250
    Hallo
    Stardiagnose allein recht halt oft nicht-am besten mit einem Oszi CAN Messen und am CAN Verteiler eins nach dem anderen abstecken und dann sieht man sofort wann der Bus wieder läuft
    Gruß
     
    jpebert gefällt das.
  6. #6 jpebert, 29.05.2021
    jpebert

    jpebert

    Dabei seit:
    07.11.2018
    Beiträge:
    4.989
    Zustimmungen:
    1.074
    Auto:
    S211 E280 CDI T vorMopf, S211 E280 T vorMopf, W211 E350 Mopf, VW LT 28 (1988), BMW X5 E70 - alles 6 Zylinder und weitere
    ... falls es überhaupt am CAN liegt. Ich möchte da gern an meinen letzten Thread zum Thema erinnern.
     
  7. #7 Counter67, 15.03.2022
    Counter67

    Counter67

    Dabei seit:
    05.12.2013
    Beiträge:
    14
    Zustimmungen:
    0
    Auto:
    Mercedes E-Klasse w211
    Und was kam hierbei raus ?
     
  8. #8 Jan_1710, 15.03.2022
    Jan_1710

    Jan_1710

    Dabei seit:
    28.05.2021
    Beiträge:
    6
    Zustimmungen:
    0
    Ich habe am Ende nichts gemacht. Scheinbar lag es am RDK-Steuergerät. Habe die Batterie länger abgeklemmt gelassen, dann war alles gut.
     
  9. #9 M.johnny97, 26.11.2022
    M.johnny97

    M.johnny97

    Dabei seit:
    26.11.2022
    Beiträge:
    7
    Zustimmungen:
    2
    Hallo,
    Wie lange hast du die Batterie abgeklemmt gelassen? Habe das gleiche problem seit räderwechsel. 1h war wohl zu wenig.
     
  10. #10 jpebert, 26.11.2022
    jpebert

    jpebert

    Dabei seit:
    07.11.2018
    Beiträge:
    4.989
    Zustimmungen:
    1.074
    Auto:
    S211 E280 CDI T vorMopf, S211 E280 T vorMopf, W211 E350 Mopf, VW LT 28 (1988), BMW X5 E70 - alles 6 Zylinder und weitere
    Falls es an einem SG liegt, was mit stromlos machen wieder zur Raison gebracht werden kann, dann reichen wenige Minuten. Demnach ist es völlig Wurscht, ob Du 30min oder 5 Tage abklemmst =)
     
  11. #11 M.johnny97, 01.12.2022
    M.johnny97

    M.johnny97

    Dabei seit:
    26.11.2022
    Beiträge:
    7
    Zustimmungen:
    2
    Habe gestern auch die Batterie getauscht. Fehler blieb aber. Mittlerweile geht garnichts mehr. Keine Lichter wenn ich die Türe öffne usw. Er lässt sich auch nicht mehr starten. Keine reaktion. Nicht mal Zündung geht an oder licht am Tacho. SAM hinten defekt? Oder doch der Batterie verteilerkasten?
     

    Anhänge:

  12. #12 Jan_1710, 01.12.2022
    Jan_1710

    Jan_1710

    Dabei seit:
    28.05.2021
    Beiträge:
    6
    Zustimmungen:
    0
    Das kann schon sein, drum hab ich das auch mal gewechselt. Hat das denn irgendwo angefangen Probleme zu machen? Ich hatte vermehrt Probleme mit dem RDK Steuergerät, wahrscheinlich hat das den Bus lahmgelegt. Kann prinzipiell erstmal alles sein, über Kabelbruch oder eins der zig Steuergeräten. ZGW und SAM Fond kannst du probieren. Gebrauchtteilen auf ebay und schick die ggf. zurück..
     
  13. #13 M.johnny97, 01.12.2022
    M.johnny97

    M.johnny97

    Dabei seit:
    26.11.2022
    Beiträge:
    7
    Zustimmungen:
    2
    Kann ich diese Steuergeräte einfach plug & play kaufe und einbauen oder muss ich das mit SD einlernen lassen?

    Vor ein paar Tagen war im SAM ein ständiges klicken von einem Relais zu hören.
     
  14. #14 Jan_1710, 01.12.2022
    Jan_1710

    Jan_1710

    Dabei seit:
    28.05.2021
    Beiträge:
    6
    Zustimmungen:
    0
    Ja das Klicken ist normal, hatte ich auch. Das hat glaub ich was mir der Zündung zu tun. Ist irrelevant.
    Kannst du beides einfach anstecken und probieren. Das Zentrale Gateway müsstest du tatsächlich codieren, allerdings funktioniert es dann dennoch besser, wenn es daran lag. Das sitzt unter dem Lenkrad.
     
  15. #15 jpebert, 02.12.2022
    jpebert

    jpebert

    Dabei seit:
    07.11.2018
    Beiträge:
    4.989
    Zustimmungen:
    1.074
    Auto:
    S211 E280 CDI T vorMopf, S211 E280 T vorMopf, W211 E350 Mopf, VW LT 28 (1988), BMW X5 E70 - alles 6 Zylinder und weitere
    Ich würde nicht empfehlen, irgendetwas zu tauschen und zu hoffen. Das ist so ziemlich die dümmste, ärgerlichste, teuerste und am wenigsten zielführende Variante.

    Üblicherweise schnappt man sich ein Multimeter, Prüflampe, Oszi, … und misst systematisch, bis man den Fehler eingegrenzt hat. Was spricht denn gegen eine fundierte Fehlersuche?
     
  16. #16 M.johnny97, 02.12.2022
    M.johnny97

    M.johnny97

    Dabei seit:
    26.11.2022
    Beiträge:
    7
    Zustimmungen:
    2
    Habe mir jetzt mal ein SAM bestellt, da ich gelesen habe "wenn das SAM defekt ist geht an Beleuchtung fast garnichts mehr." Was ja auch der Fall ist. Ich habe aber auch gelesen, dass das SAM meistenst beim Batterie tausch oder bei Starthilfe abgeschossen wird.

    Jetz meine Frage. Soll ich erst das SAM tauschen und dann die Batterien anklemmen und damit wieder riskiren, dass ich das SAM abschieße oder erst die vordere Batterie anklemmen dann das SAM tauschen und danach die hintere Batterie anklemmen?

    Oder sollen überhaut beide Batterien zuerst angeklemmt werden und danach das SAM getauscht werden?
     
  17. #17 M.johnny97, 02.12.2022
    M.johnny97

    M.johnny97

    Dabei seit:
    26.11.2022
    Beiträge:
    7
    Zustimmungen:
    2

    Dagegen spricht das fehlende Know-how meinerseits, und dass ich den Wagen aktuell auch nicht ohne Abschleppdienst richtung Werkstatt fahren kann.

    Bin mir auch nicht sicher ob in dieser "FACHWERKSTATT" auch jemand mit oszi umgehn kann. Stundenlange Fehlersuche ohne erfolg möcht ich mir versuchen zu spaaren.

    Hatte schon schlechte Erfahrungen dort :rolleyes:
     
    Jan_1710 gefällt das.
  18. #18 Jan_1710, 02.12.2022
    Jan_1710

    Jan_1710

    Dabei seit:
    28.05.2021
    Beiträge:
    6
    Zustimmungen:
    0
    Ja das kann passieren, allerdings ist das lange nicht die Regel wie es im Internet rüberkommt. Es geht eher altersbedingt mal kaputt, als dass die Batterie es zerstört. Lass die Batterie dran, da ansonsten das ganze Auto stromlos ist und die Energieschwankungen wesentlich höher sind. Sollte aber am Ende auf das gleiche rauskommen, egal wie rum du es machst. Vielmehr Möglichkeiten bleiben nicht.
     
  19. #19 M.johnny97, 06.12.2022
    M.johnny97

    M.johnny97

    Dabei seit:
    26.11.2022
    Beiträge:
    7
    Zustimmungen:
    2
    hab nun auch das SAM getauscht und es hat sich leider nichts geändert.

    Erst hat alles gut ausgesehn. Batterie dran geklemmt, Türe aufgemacht, alle Lichter leuchten wie sie sollen.
    Zündung eingeschaltet alles ohne fehler. Doch als ich dann den Motor gestartet habe, spielte wieder alles verrückt...

    Bevor es zu diesen Problemen gekommen ist wurde der DPF von einer Firma freigebrannt, Differenzdruckgeber und Temperatur Sensor getauscht.

    Wäre es theoretisch möglich das ein defekter Temperatursensor diese Störungen im canbus verursacht?

    Am selben Tag hab ich dann auch Winterreifen montiert. Danach Reifendruckkontrolle genullt.

    Oder doch RDK Steuergerät defekt?

    Das alles war am Montag 21.11.22
    Probleme begannen dann Dienstag Abend. Erst mit kurzen ausfällen und dann täglich schlechter werdend.
     
  20. #20 jpebert, 07.12.2022
    jpebert

    jpebert

    Dabei seit:
    07.11.2018
    Beiträge:
    4.989
    Zustimmungen:
    1.074
    Auto:
    S211 E280 CDI T vorMopf, S211 E280 T vorMopf, W211 E350 Mopf, VW LT 28 (1988), BMW X5 E70 - alles 6 Zylinder und weitere
    Da die Sensoren nicht am CAN-Bus hängen, sondern am MSG, können die den CAN-Bus nicht direkt stören. Hast Du mit dem Oszillographen tatsächlich überprüft, ob der CAN-Bus überhaupt das Problem ist? Und wenn ja, ist es der CAN-Bus zumeist selbst nicht sondern ein defektes SG.

    DU solltest dem Hinweis von @stin nachgehen und die SGs vom Motorraum - CAN abklemmen und nach und nach wieder anstecken, damit Du siehst, welches SG einen Defekt hat. Du fängst sicherlich mit den SGs, wo die CAN-Bus-Endwiderstände integriert sind, an.

    Ein multiples SG-Versagen halte ich nicht für ausgeschlossen.
     
Thema:

CAN-Bus komplett tot.

Die Seite wird geladen...

CAN-Bus komplett tot. - Ähnliche Themen

  1. Can Bus Klemme 15 Radio

    Can Bus Klemme 15 Radio: Hallo, ich habe durch Dummheit das geschaltete Plus im Isostecker mit Maße gebrückt. Es hat klick unter dem Lenkrad gemacht und die 15A Sicherung...
  2. W221 ESP/ABS CAN BUS - Probleme

    W221 ESP/ABS CAN BUS - Probleme: Hallo liebes Forum, seit Tagen plagt mich ein großes Problem mit meinem 10/2006 W221 S320 CDI. Vorgeschichte Nach wochenlanger Suche konnte ich...
  3. PDC Nachrüsten, Schaltplan Steuergerät und CAN-BUS Steckplatz

    PDC Nachrüsten, Schaltplan Steuergerät und CAN-BUS Steckplatz: Hallo Zusammen, bin fleißig bei meiner C-Klasse S204 BJ 09/2011 die PDC nachzurüsten. Habe mir alle nötige Teile gekauft und bin jetzt stehen...
  4. Mercedes O309D Bus - Fahrzeugidentifikationsnummerliste

    Mercedes O309D Bus - Fahrzeugidentifikationsnummerliste: Hallo, Ich suche eine Liste mit Fahrzeugidentifikationsnummern für den Mercedes O309D Bus. Ich schreibe einen Artikel über die Geschichte des...
  5. Spritverbrauch durch Schubabschaltung beim 208 Bus senken

    Spritverbrauch durch Schubabschaltung beim 208 Bus senken: Unser 208 Bus verbraucht 17,5 Liter Benzin auf 100 Kilometer. Wir haben viel Spaß mit diesem Oldtimer (James Cook). Zündung und Ventile haben wir...