ML W164 Motor startet und geht direkt wieder aus

Diskutiere ML W164 Motor startet und geht direkt wieder aus im Geländewagen und SUV Forum im Bereich Mercedes-Fahrzeuge; Guten Tag Ich habe mir vor ca 9 Monaten einen W164 gekauft, kurze Zeit später fing er während der fahrt an zwei mal zu piepen und das ca alle...

  1. S.tsr

    S.tsr

    Dabei seit:
    27.05.2021
    Beiträge:
    3
    Zustimmungen:
    0
    Guten Tag

    Ich habe mir vor ca 9 Monaten einen W164 gekauft, kurze Zeit später fing er während der fahrt an zwei mal zu piepen und das ca alle zwei Minuten.
    Gestern fing er während der Fahrt an schneller zu piepen und ging plötzlich aus und ging direkt wieder an und sofort wieder aus und hat wie wild gepiept. Nach mehrmaligen Starten blieb er wieder an.
    Einige Zeit später ging er wieder aus und seitdem startet er und geht immer direkt wieder aus und piept.
    Man kommt nicht ins Motorsteuergerät zum auslesen, alle anderen Steuergeräte lassen sich auslesen.
    Ich denke es hängt mit der Wegfahrsperre zusammen und das es vielleicht das EZS ist.
    Hatte hier schon jemand das gleiche Problem ?

    Mit freundlichen Grüßen

    Sascha
     
  2. #2 jpebert, 28.05.2021
    jpebert

    jpebert

    Dabei seit:
    07.11.2018
    Beiträge:
    3.406
    Zustimmungen:
    845
    Auto:
    W211 E280 CDI T vorMopf, W211 E350 Mopf, VW LT 28 (1988), BMW X5 E70 - alles 6 Zylinder
    Naja, klingt auf alle Fälle nach einem interessanten Problem.

    1. Was hindert Dich, hier mehr Diagnoseinformationen preiszugeben. Z.B. das Fehlerprotokoll einzustellen.
    2. Was steht im KI, wenn er piept?
    3. Eine vernünftige Diagnose zum Auslesen benutzt?

    Zugriff aufs MSG wirst Du Dir zuerst verschaffen müssen. Also MSG tauschen wenn defekt, oder die Komponenten die die CAN-Bus-Kommunikation zwischen Diagnose und MSG stören (andere SGs, Kabel, ZGW, ...).
     
    conny-r gefällt das.
  3. S.tsr

    S.tsr

    Dabei seit:
    27.05.2021
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo jpebert

    Der ML stand bis jetzt in der Garage und ich habe mich leider nicht mehr drum gekümmert. Ich habe heute ein neues SAM rear verbaut , da das alte ziemlich vergammelt war und da auch ein haufen Fehler abgelegt waren.
    Die Versorgungsspannung vom MSG habe ich geprüft und diese ist i.O.
    Ich habe versucht die Fehler auszulesen allerdings komme ich fast niergendwo rein ( Gateway angeblich i.O. laut Tester ) .
    Ich habe mal paar Fotos gemacht von dem was der Tester ausspuckt und außerdem ein kleines Video gemacht , was passiert wenn ich die Zündung einschalte. Wenn ich Starte spring er kurz an und geht direkt nach 1 Sekunde wieder aus und das gepiepe beginnt von vorne.
    Das Problem war anfangs sporadisch und ist jetzt permanent.



    Ich hoffe du oder jemand anders hat noch eine Idee wie ich weiter vorgehen soll .

    Mit freundlichem Gruß
     

    Anhänge:

  4. #4 jpebert, 16.10.2021
    jpebert

    jpebert

    Dabei seit:
    07.11.2018
    Beiträge:
    3.406
    Zustimmungen:
    845
    Auto:
    W211 E280 CDI T vorMopf, W211 E350 Mopf, VW LT 28 (1988), BMW X5 E70 - alles 6 Zylinder
    Habe keine Idee. Die CANs laufen am ZGW zusammen. Das scheint tatsächlich zu funktionieren, da einige SGs sichtbar sind. Aber das ZGW ist auch der Knotenpunkt, wo die Diagnose angeschlossen ist. Ob der dann korrekt die CAN - Busse verbindet bzw. zum Diagnoseport durchreicht ist fraglich.

    Ich würde zunächst ein anderes ZGW verbauen und Codieren und prüfen, ob die CAN-Busse funktionieren.
     
  5. S.tsr

    S.tsr

    Dabei seit:
    27.05.2021
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo ,

    habe mal mit einem anderen Tester (Gutmann) ausgelesen und folgende Fehler wurden ausgespuckt ( Siehe Bilder) .


    Mit freundlichen Grüßen

    Sascha
     

    Anhänge:

  6. #6 jpebert, 21.10.2021
    jpebert

    jpebert

    Dabei seit:
    07.11.2018
    Beiträge:
    3.406
    Zustimmungen:
    845
    Auto:
    W211 E280 CDI T vorMopf, W211 E350 Mopf, VW LT 28 (1988), BMW X5 E70 - alles 6 Zylinder
    Naja, da Du irgendwo anfangen musst ... Prüf' doch erstmal die Stromversorgung der beanstandeten Steuergeräte (Klemme 87). Liegt keine Versorgung an, dann prüfst Du die Zuleitungen inklusive der Relais, die den Strom schalten.

    Funktioniert das alles, dann zunächst alles vom Motorraum-CAN abstecken bis auf das ZGW und danach schrittweise wieder alle SGs anschließen beim MSG angefangen, da im MSG und ZGW die Abschlusswiderstände für den CAN-Bus integriert sind. Du prüfst dann jedesmal mit der SD, ob Du auf das SG kommst. Wenn Du ein Oszilloskop hast, dann kannst Du auch gleich auf den CAN schauen, ob dort vernünftige Signale zu sehen sind. Irgendwann hast Du den Störer gefunden, wenn es einen Fehler auf dem CAN-Bus gibt.

    Das Problem kann aber vielschichtiger sein. Du musst Dich mit Multimeter und etwas Messen durchbeißen, bis Du den Fehler gefunden hast.
     
Thema:

ML W164 Motor startet und geht direkt wieder aus

Die Seite wird geladen...

ML W164 Motor startet und geht direkt wieder aus - Ähnliche Themen

  1. W164 teilweise keine Leistung

    W164 teilweise keine Leistung: Hallo Zusammen Zu hülf. Unser ML will nicht so richtig. Wenn wir zb morgens los wollen ist alles ok. Stopp an der Tanke, Auto aus, Auto an und...
  2. ML 320 cdi w164

    ML 320 cdi w164: Hey Leute, ich habe einen ML 320 cdi bj 05.2008 Ich habe ein Problem am Automatikgetriebe. Wenn das auto auf P steht rasselt irgendwas im...
  3. W164 Radio geht nach 30Sek. aus und startet nicht mehr richtig

    W164 Radio geht nach 30Sek. aus und startet nicht mehr richtig: Guten Abend zusammen. Leider habe ich seit 2 Tagen folgendes Problem: Das Radio in meinem W164 280 cdi 4matic Bj06 ging das Radio plötzlich aus....
  4. Dieselverlust beim W164

    Dieselverlust beim W164: Moin zusammen, hätte noch einmal eine Frage an´s Forum, da ich auch nach Nutzung der Suchfunktion und in anderen Foren keine Lösung gefunden...
  5. W164 Ml280 2007 BJ - Motor Probleme

    W164 Ml280 2007 BJ - Motor Probleme: Hallo liebe Gemeinde, Ich bin Laie und wollte ein größeres Auto mir zulegen. Gestern habe ich einen gebrauchten Ml 280 Diesel gekauft mit...