Problem: OBD2 Geschwindigkeit nur bis 255 km/h (8 bit)

Diskutiere Problem: OBD2 Geschwindigkeit nur bis 255 km/h (8 bit) im Automobiles Allerlei Forum im Bereich Rund ums Auto; Hallöchen zusammen, ich habe schon ziemlich viel umher gesucht, leider weiß ich nun nicht mehr an welcher Stelle ich noch suchen soll :D Die...

  1. FUKU

    FUKU

    Dabei seit:
    24.07.2020
    Beiträge:
    3
    Zustimmungen:
    1
    Hallöchen zusammen,

    ich habe schon ziemlich viel umher gesucht, leider weiß ich nun nicht mehr an welcher Stelle ich noch suchen soll :D

    Die Situation:
    Ich habe einen OBD2 Adapter ( Amazon: kungfuren OBD2 Bluetooth 4.0 Adapter <- darf hier wohl keinen Link posten ) der laut Beschreibung alle Protokolle kann (zumindest die die ich im Zusammenhang mit OBD2 gefunden habe).
    Ich nutze ihn mit Torque Pro und das Auslesen/Aufzeichnen(!) von Sensoren klappt soweit ganz gut. Das Fahrzeug ist eine 2020 W213 E-Klasse.

    Das Problem:
    Ab 255 km/h wird nur noch 255 als Wert aufgezeichnet.

    Grund:
    Die Geschwindigkeit wird nur als 8 Bit Wert gelesen.

    Nun die Frage:
    Wird denn auf dem Datenbus nur ein 8 Bit Wert gesendet? Gibt es also eine Möglichkeit irgendwie die richtige Geschwindigkeit ab 255 km/h auszulesen? Evtl. mit einem anderen Adapter? Da gibts ja auch welche im dreistelligen Bereich...

    Hoffe hier finde ich eine Antwort :)

    Gruß
     
    Kevin.Bergmann030 gefällt das.
  2. #2 conny-r, 25.07.2020
    conny-r

    conny-r

    Dabei seit:
    07.11.2010
    Beiträge:
    6.322
    Zustimmungen:
    993
    Auto:
    S 205 220d T 02 / 2017 9G SL 350 Sportmotor 316 PS
    Dann poste mal ohne http
     
  3. #3 Kevin.Bergmann030, 25.07.2020
    Kevin.Bergmann030

    Kevin.Bergmann030

    Dabei seit:
    12.01.2020
    Beiträge:
    87
    Zustimmungen:
    6
    Ich habe den selben Adapter. Du kannst einstellen das er die Geschwindigkeit vom GPS Signal nimmt. Das funktioniert bestens. Freundliche Grüße Kevin
     
  4. #4 nelke1234567, 25.07.2020
    nelke1234567

    nelke1234567

    Dabei seit:
    30.09.2012
    Beiträge:
    374
    Zustimmungen:
    60
    Auto:
    230E / 200E / C200 / C200 / E200
    Die Geschwindigkeit wird intern mit 0,1 km/h Auflösung übertragen. Und weit über 400.
    Du benötigst lediglich einen CAN-Monitor und die richtigen Adresssen und Bits.
     
    FUKU gefällt das.
  5. FUKU

    FUKU

    Dabei seit:
    24.07.2020
    Beiträge:
    3
    Zustimmungen:
    1
    hatte ich probiert es reichte schon wenn man Amazon und danach de mit paar Slashes hat.... Aber über den namen sollte man das Teil ja trotzdem finden.

    Ja GPS funktioniert. Ich brauche aber die Geschwindigkeit aus dem System :) Auch geht es mir hauptsächlich ums Aufzeichnen der Daten.

    Danke für die Antwort. Ja im Track-Pace (intern) wird sie mir auch mit 0.1 km/h Auflösung angezeigt.
    Also laut obd-2.net sollte auf dem OBD2 Stecker auch der CAN-Bus laufen... Mein Adapter soll das laut Beschreibung auch können. Ich geh einfach mal davon aus dass Torque Pro das auch können sollte... (weiß zwar nicht wie aber das lässt sich sicher rausfinden)
    Nun zur Adresse und den Bits... Wie? Woher krieg ich die Info? :D
     
  6. #6 conny-r, 25.07.2020
    conny-r

    conny-r

    Dabei seit:
    07.11.2010
    Beiträge:
    6.322
    Zustimmungen:
    993
    Auto:
    S 205 220d T 02 / 2017 9G SL 350 Sportmotor 316 PS
    FUKU gefällt das.
  7. #7 conny-r, 27.07.2020
    conny-r

    conny-r

    Dabei seit:
    07.11.2010
    Beiträge:
    6.322
    Zustimmungen:
    993
    Auto:
    S 205 220d T 02 / 2017 9G SL 350 Sportmotor 316 PS
    Hier ein Screen von Torque Pro, GPS Daten.
    Screenshot_20200727-015850_Gallery.jpg
     
  8. FUKU

    FUKU

    Dabei seit:
    24.07.2020
    Beiträge:
    3
    Zustimmungen:
    1
    Hmmm... Push
     
Thema:

Problem: OBD2 Geschwindigkeit nur bis 255 km/h (8 bit)

Die Seite wird geladen...

Problem: OBD2 Geschwindigkeit nur bis 255 km/h (8 bit) - Ähnliche Themen

  1. Problem beim Starten: Nichts passiert, blockierte Automatik

    Problem beim Starten: Nichts passiert, blockierte Automatik: Hallo liebe Community, ich habe folgendes Problem bei meinem W203 Bj. 2001: Zu meinem Auto: Steht immer im trocknen in einer Garage Bj. 2001 Ca....
  2. 209 Problem mit Ölstandsmessung

    Problem mit Ölstandsmessung: Moin Zusammen, seit bald einem Jahr bin ich stolzer Besitzer eine A209 200 Kompressor. Bisher habe ich immer darauf vertraut, dass sich der...
  3. Problem mit dem kühlsystem. Kühlflüssigkeit kommt nicht in den Ausgleichsbehälter zurück.

    Problem mit dem kühlsystem. Kühlflüssigkeit kommt nicht in den Ausgleichsbehälter zurück.: Wie es heißt, kehrt das Kühlmittel nicht zum Behälter zurück . In den Mercedes haben sie mein Behälter im Februar ersetzt, aber das gleiche...
  4. W212 E350 CGI Problem

    W212 E350 CGI Problem: Guten Tag zusammen, ich bin neu als Mitglied und habe folgendes Problem. Ich habe einen W212 E350 CGI 292 PS jedenfalls der Wagen macht mich...
  5. Problem Lenkung W163

    Problem Lenkung W163: Hallo, ich habe seit langer zeit ein riesiges Problem mit der Lenkung. Beim rechts einschlagen habe ich ein starkes Rubbeln beim fahren (also beim...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden